SwedeSpeed - Volvo Performance Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have 2 Volvo XC70 that are experiencing somewhat similar problems. I have been working on Volvos for 30 years. Our shop subscribes to VIDA and has access to TechNet notes and VolvoTechinfo. I have searched for pertinent bulletins relating to these problems to no avail. Both of these cars intermittently spaz out while driving. Things such as the wipers spontaneously turning on, the lights and turn signals stop working, the power windows stop working, the sunroof stops working, the srs light comes on and the dash panel goes blank and the qauges stop working. the car continues to drive, however. There are numerous codes stored. We replaced the SWM on one car and sent it out only to have it come back two weeks later with the same problem. there are ECM codes, CEM codes, DIM codes and many more. are there any techs out there who may have encountered a similar problem? these are both 2004 model year XC70s.
 

·
Registered
Joined
·
79 Posts
Re: 2004 XC70 odd electrical behaviour (scandi1)

Bad ECUs. Bad lot from manufacturer.<p> <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/cool.gif" BORDER="0">
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Re: 2004 XC70 odd electrical behaviour (hethaerto)

Which ECU? The ECM, or the CEM? Does Volvo admit this? <IMG NAME="icon" SRC="http://www.vortexmediagroup.com/images/banghead.gif" BORDER="0"> <BR><BR>
<i>Modified by scandi1 at 6:06 AM 6-23-2009</i>
 
1 - 3 of 3 Posts
Top