SwedeSpeed - Volvo Performance Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·



A little bit of backstory. My previous car was a 2002 Ford Taurus that decided to throw it's tranny one day. And this is what I replaced it with, a 2004 Volvo V70 2.5T with 130,xxx miles on it.


The previous owner is a car mechanic, so the car was taken car of for the 3 months he had it. He cleaned/redid the PCV system, the timing belt and related components were all replaced, new brake pads, and new fluids where appropriate.

But he missed some things. Nothing major, but they are things I need to get done. The rear wiper motor has seized, so it's disabled currently (easy fix, no questions there). He skipped over the rotors, and they are pretty worn, so they're on the list to get replaced. I want to redo the audio system, as some of my speakers are going, but I don't see that being a problem. There is a supposed axle seal leak (I say supposed, because I haven't gotten it onto a lift yet, and I can't tell what kind of fluid it is from the residue on the ground, the previous owner brought it to my attention). And something is going on with the temp gauge/headunit. So here are my questions.

Where to source parts?
I know of IPD, FCP, and eEuroParts, but I don't know if I'm missing out on anywhere else.

Brake rotor size?
Is there an easy way to find it out besides going and measuring them? I've tried googling, but nothing has really come up. I believe I have the 16" wheels, haven't checked yet.

What to do with the leak?
Well obviously it needs to get fixed. So if it is an axle seal, I believe I'm just going to replace the axle on it, as from what I've read, just getting to the leak is involved and the axle is already off. I don't know, still undecided. So replace just the seal or the whole axle too?

What is going on with my temp gauge?
Here is what it does. When I start the car, the gauge stays low, and it takes a couple minutes to reach midpoint. During the time it takes to reach the middle, my headunit will flash and my steering wheel controls will not work at all. I haven't found my exact problem while googling, but it has lead me to believe that a new thermostat would solve the problem. The car came with a HU-613 if that helps.
 

·
Registered
Joined
·
241 Posts



A little bit of backstory. My previous car was a 2002 Ford Taurus that decided to throw it's tranny one day. And this is what I replaced it with, a 2004 Volvo V70 2.5T with 130,xxx miles on it.


The previous owner is a car mechanic, so the car was taken car of for the 3 months he had it. He cleaned/redid the PCV system, the timing belt and related components were all replaced, new brake pads, and new fluids where appropriate.

But he missed some things. Nothing major, but they are things I need to get done. The rear wiper motor has seized, so it's disabled currently (easy fix, no questions there). He skipped over the rotors, and they are pretty worn, so they're on the list to get replaced. I want to redo the audio system, as some of my speakers are going, but I don't see that being a problem. There is a supposed axle seal leak (I say supposed, because I haven't gotten it onto a lift yet, and I can't tell what kind of fluid it is from the residue on the ground, the previous owner brought it to my attention). And something is going on with the temp gauge/headunit. So here are my questions.

Where to source parts?
I know of IPD, FCP, and eEuroParts, but I don't know if I'm missing out on anywhere else.

Brake rotor size?
Is there an easy way to find it out besides going and measuring them? I've tried googling, but nothing has really come up. I believe I have the 16" wheels, haven't checked yet.

What to do with the leak?
Well obviously it needs to get fixed. So if it is an axle seal, I believe I'm just going to replace the axle on it, as from what I've read, just getting to the leak is involved and the axle is already off. I don't know, still undecided. So replace just the seal or the whole axle too?

What is going on with my temp gauge?
Here is what it does. When I start the car, the gauge stays low, and it takes a couple minutes to reach midpoint. During the time it takes to reach the middle, my headunit will flash and my steering wheel controls will not work at all. I haven't found my exact problem while googling, but it has lead me to believe that a new thermostat would solve the problem. The car came with a HU-613 if that helps.

Tascaparts.com is a good source for the Oem parts (They are a Volvo dealer) they have pretty good discounts compared to other dealers
 

·
Registered
Joined
·
161 Posts
If it helps concerning brake size, I believe the base and 2.4t had the same rotor size, and the T5 had the larger rotors. I upgraded my car to the T5 rotors, and learned they were 303mm (or something just north of 300mm), and my old rotors were 275mm or something along those lines.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Right. I guess I'm just gonna have to go out and measure them.

Anybody have any idea about the temp gauge? I payed attention to it a little more, and the blinking stops and the controls work once the needle gets above the lowest dash. So it really sounds like a thermostat problem. Can anyone confirm?
 
1 - 4 of 4 Posts
Top