SwedeSpeed - Volvo Performance Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2004 S60 R, manual transmission with 120K miles. Just had the timing belt changed so my plan is to keep the car. I"m hoping what happened in the last two days isn't going to make me regret keeping the car. I was travelling on the PA turnpike when all of a sudden the left rear door warning light came on. Only problem was that the door was shut tight. I heard a couple of odd noises and with in 5-10 mins the entire dash was dead. No odometer, speed, turn signals, tach or brake lights. I did have windshield wipers and headlights. When I pulled over and turned the engine off and restarted everything came back. The next hour drive was uneventful. The following day I had no problems driving from Baltimore to Pittsburgh for the first 3 hours. Then same thing happened with the warning light falsely indicating my left rear door was open. With in 30 mins all of the dash board gauges were out again except for headlights, radio and wipers. I had no brake lights or guages. The warning message prior to the entire dash black out also said that SRS airbag needs urgent service.

Any thoughts on why this happenings would be appreciated as well as best way to fix.
 

·
Registered
Joined
·
31 Posts
As far as I know, the door switches are hard-wired to the CEM. The SRS maintenance message occurs on failure on the low-speed can network. A dying battery is a quite good explanation, water on the CEM connector is another. It should be located near the driver's feet, but I don't know the exact position.
What I do know is, corrosion on the connector is not uncommon.

When the failure ocurred, were the wipers still working on level 1? In my experience, they only work in level 2 then.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Thanks for the reply. As far as I know it's the original battery. Interesting that you mentioned the wipers. I was driving two days after "Sandy" and there was a significant amount of rain on the ground. The wipers worked, only one speed and I had to time the turn off so the wiper could lay down.
 
1 - 4 of 4 Posts
Top