SwedeSpeed - Volvo Performance Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I purchased my car used two years ago and have never had a problem with it. Recently, it suddenly loses power then coughs and continues moving. Twice I've lost complete power sat for five minutes then it fires up again as though there was no event. I am thinking that this may be related to my fuel-injection system. Perhaps the injectors are clogged. If anyone has any feeback in this regard I welcome all ideas. Thank-you
 

·
Registered
Joined
·
4,678 Posts
Re: 2004 S60 2.5 (Tiny)

Could be a clogged TCV....order the IPD HD-TCV.
 

·
Registered
Joined
·
1,537 Posts
Re: 2004 S60 2.5 (PureDrive07)

Quote, originally posted by PureDrive07 »
Could be a clogged TCV....order the IPD HD-TCV.

If it was the TCV that would mean he jsut wouldn't be boosting. He said he lost power completely. It wouldn't make that big of a problem.

ETM Recall maybe?
 

·
Registered
Joined
·
2,999 Posts
Re: 2004 S60 2.5 (cmurphy2266)

Quote, originally posted by cmurphy2266 »
ETM Recall maybe?
Correct me if I'm wrong, but I thought that the ETM was an issue only in the 2001 S60
 

·
Registered
Joined
·
1,844 Posts
Re: 2004 S60 2.5 (Elsesteo)

Sounds similar to a problem I had a while ago with my fuel rail sensor. Are you getting an intermittent CEL.?
Kind of putt putt then you hit the gas and it goes, when it dies it starts back up in a few like nothing.?
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top