SwedeSpeed - Volvo Performance Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2,697 Posts
Discussion Starter · #1 · (Edited)
Hello all

I have a 2001 Volvo S80 T6 with about 150k on the clock.

Recently I replaced the radiator and after that, the car would not start anymore. It makes a whirring noise coming from the driver's side of the engine compartment and that's it. No clicking, no turnover. The cogs/belts all turn etc. Checked all fuses and everything is good there. Thinking perhaps some of the wires in the various harnesses got knocked out of place?

Any advice? This is a total mystery to me.
 

·
Registered
Joined
·
1,137 Posts
Every morning a rooster crows before the sun comes up. There's a 100% correlation between the rooster crowing and the sun rising. Could the rooster be causing the sun to come up? The only way to disprove the hypothesis would be to kill every rooster on the face of the planet! They could be engaged in a global rooster jihad and you can never be too safe and secure. :rolleyes:

Just because the radiator is last thing you did doesn't prove it has anything to do with this issue... which doesn't really help you, I know. Wild guesses: clogged fuel filter, bad coil on cyl #1 next to belt. A code reader might give a decent clue, I use BSR's PPC Diagnostic.
 

·
Registered
Joined
·
2,697 Posts
Discussion Starter · #3 ·
I only mention it in case it might be connected. I am perfectly aware of correlations and their implications for something being causal or not as I'm pursuing a PhD so yeah.

Really all I needed was the last part, thanks.
 

·
Registered
Joined
·
1,511 Posts
Hope you will get to the root of the problem.
 
1 - 4 of 4 Posts
Top