SwedeSpeed - Volvo Performance Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
445 Posts
Discussion Starter · #1 · (Edited)
Okay, it's actually an S80 but close enough.

Out shopping today, and got in the car and hit the key and nothing. Headlamps go down, Check Engine light goes out, but won't crank. I'd been having a little trouble with the starter not disengaging so I knew it was on it's way out. Had the car towed home, just replaced the starter. Still won't crank. Battery is an AC Delco about 6 weeks old, shows 12.1V. Hear some clicks and gurgles under the hood but with these engines, a lot is going on. One thing I see in Vida is that the voltage stays rock steady when I have the key in Pos III.

Vida shows nothing but the usual old faults (rain sensor wipers, power mirror issue, hall switch in door windows... nothing engine related)

TIA
 

·
Registered
Joined
·
17,449 Posts
12.1 sounds low to me. Did you jump it?
Maybe your alternator is failing/has failed? Battery that new should be upwards of 13+ no?
 

·
Registered
Joined
·
3,575 Posts
Starter relay? My engine control relay went out on my 2.5T. Same part number as the starter relay. I swapped them to diagnose and started having no crank problems.
 

·
Registered
Joined
·
2,349 Posts
Voltage and charge may not be the issue with the battery. Have it's health and load tested. You could have 100% charge but have bad battery health meaning the Cranking Amps are below what the car needs to turn over. I've had this before where it was down to 23% health and putting out less than 180 CCA which will not turn over the car. Check that since you mention your starter wasn't disengaging. Also when I had this, I had no unusual behaviour other than the car wouldn't crank. New battery and it was fine. With only 6 weeks on yours it should be replaced for free if it's internally dead. Good luck!!

Sent from my Huawei Mate 9 using Tapatalk
 

·
Registered
Joined
·
445 Posts
Discussion Starter · #5 ·
Tested some more, no voltage at the solenoid. What is the location of thr starter relay?
 

·
Registered
Joined
·
3,575 Posts
It's in the electrical box behind the engine air filter box. I'm sure there's an official Volvo term for it.
 

·
Registered
Joined
·
445 Posts
Discussion Starter · #7 ·
Der relayen boxen
 

·
Registered
Joined
·
443 Posts
I would make sure the engine is grounded to negative first. Get a jumpstart cable and connect metal part on the engine to a metal part on the frame. Than try. To crank it.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
445 Posts
Discussion Starter · #10 ·
I'm beginning to suspect it's the key antenna induction coil
 

·
Registered
Joined
·
445 Posts
Discussion Starter · #11 ·
Took me about 2 weeks and a dozen fuses. I found the solenoid fuse blown (35A). It would fail intermittently, sometimes 5 in a row. In fact, the last straw was when my gf and I were at a diner in separate cars, and mine wouldn't start and neither would her cruiser! We're just looking across at each other like a couple of idiots hahaha.

Anyway, the solenoid wire must have shorted in the harness somewhere. I cut it at the fuse block and sistered in a new wire and all has been well (what that at least) for the past month.

Thanks...
 
1 - 11 of 11 Posts
Top