SwedeSpeed - Volvo Performance Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
My car has started doing this and it's getting worse... at start up, it sometimes stauls out and it takes several attempts to get the engine to crank back over. In park and in drive when coming to a stop, the engine surges between 700 and 1,000 RPM's. It sounds really bad in park. When I'm slowing down to stop, sometimes the car will actually surge forward a bit.

Last night i unplugged the battery for about 15min. The check engine light went away and the surge has lessened a little bit, but it's still there.

Might be important to note I have had a coolant leak for a few months.

HELP?!
 

·
Registered
Joined
·
217 Posts
What code came up with your cel? Are you on your original Etm? Cleaned your maf?
 

·
Registered
Joined
·
2,126 Posts
^^ Take your car to an autozone and have them read the CEL if you do not have an obd2. Also, try cleaning out your IAC.
 

·
Registered
Joined
·
63,541 Posts
MILEAGE always helps here, but you probably need a new ETM and a MAF sensor
 

·
Registered
Joined
·
13 Posts
Discussion Starter #10
it's 1999 V70R with 171,000 miles... thank u all so much for your help. can i buy these parts after market? is it expensive to replace or a DIY?
 

·
Registered
Joined
·
2,126 Posts

·
Registered
Joined
·
217 Posts
thanks again everyone. it has been a little bit better since i unplugged the battery. why would this help anything?
It resets the ECU so it has to relearn the configuration.

After I replaced my MAF, it still ran $4!tty but then I read some more, and unplugged the battery and plugged it back on II and it was fine.

Do a drive cycle or two so it really is in tune with your car.


http://www.matthewsvolvosite.com/drive-cycle.html
 
1 - 14 of 14 Posts
Top