SwedeSpeed - Volvo Performance Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I own a 1998 S70 T5 with and upsolute 17psi tune

When I am accelerating in first it makes 7 psi and that is normal but 2nd-5th it boosts to 17 psi normally.
Recently while accelerating it felt kinda doggy in second and I looked at my boost gauge and i was only making 11 psi. Then I shifted to 3rd and it hit 15 psi then dropped to 10 psi, fourth it hit 15 and held it for a short time. Then I shifted to second and it hit 17 psi then dropped to 10 psi then just went back and fourth between them.

I did a few pulls with varying but similar results on each. Occasionally it will boost properly but the problem seems to keep happening the more I drive.

Has anyone encountered this before? could it be a faulty wastegate or maybe a boost controller?
Thank.
 

·
Registered
Joined
·
17,684 Posts
replace boost controller with a genuine but upgraded piedberg valve. your boost level is above the working design for the stock iirc
 

·
Registered
Joined
·
560 Posts
replace boost controller with a genuine but upgraded piedberg valve. your boost level is above the working design for the stock iirc
I have been hearing about this "upgraded OEM Pierberg" valve. It seems some people are saying the OEM style valves are better when compared to the MAC style valves which seem to be falling out of favor. Is this an OEM part for a newer model Volvo or other car or something? Where can one find this valve and how is it identified as being 'upgraded'?
 

·
Registered
Joined
·
17,684 Posts
It's made by the oem manufacturer but to higher standards, IIRC they are used on audis
 
1 - 6 of 6 Posts
Top