SwedeSpeed - Volvo Performance Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
A month or so ago, I picked up a 1997 960. The car has generally been great so far, but it's got one nagging issue that I'd like to fix if possible. <p>At low speeds, when the wheel is turned, I get a shudder/growling noise from somewhere in the steering system. You can feel it through the wheel, but it doesn't shake it back and forth or anything like that. There's no similar symptoms at highway speeds-this only occurs under 15 mph or so. <p>What should I be looking at? Steering rack? Power steering pump? Something else? <p>Thanks in advance for any help.
 

·
Premium Member
Joined
·
19,953 Posts
Re: 1997 960: Steering issues (TheJeffers)

Is this '97 960 the car you bought instead of the 850?...<p><A HREF="http://forums.swedespeed.com/zerothread?id=111042" TARGET="_blank">http://forums.swedespeed.com/zerothread?id=111042</A><p>Good!<p>Be sure the power steering reservoir is not too full or not too low and has the correct type fluid.<br>Inspect the rubber components of the steering system for deterioration, displacement and/or leaks.<br>Avoid turning the steering wheel full-lock at any speed.<br>Be sure the drive belt is in good condition and properly tensioned.<br>Check the power steering pump mounts for deterioration and/or displacement.<p>For more do's and don't's click around on this...<p><A HREF="http://www.brickboard.com/FAQ/700-900/Steering.htm" TARGET="_blank">http://www.brickboard.com/FAQ/700-900/Steering.htm</A><p>George Dill<br>
 

·
Registered
Joined
·
7,614 Posts
Sorry I missed this thread when it was posted. I sold TheJeffers this car. (I saw the link in the want ads)<p>If I may shed a little light, Something not mentioned is that the steering rack was replaced with a brand new unit in April of '08 and it had this issue both before and after the replacement, and the serpentine belt was replaced earlier this year.<p>Swap the power steering pump, it's the only other thing in the system that isn't brand new. I was waiting for the noise to get a little worse before I dove in and did that, but it never got worse in the year I drove the car.<p>How's the car been treating you otherwise?
 

·
Registered
Joined
·
1,930 Posts
Re: (LloydDobler)

My '96 960 does the exact same thing. The car only has 58K on it, and it's done if from the day I purchased it with 30K on it. Nothing leaks on this car, it's like new. It might be nothing more than the nature of the beast as well as a minor annoyance.<br>
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
Re: (LloydDobler)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>LloydDobler</b> »</i></TD></TR><TR><TD CLASS="quote"><br>Swap the power steering pump, it's the only other thing in the system that isn't brand new. I was waiting for the noise to get a little worse before I dove in and did that, but it never got worse in the year I drove the car.</TD></TR></TABLE><p>That's just the thing-it hasn't gotten any worse for me, either, and it hasn't annoyed me enough to do anything about it. <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/biggrin.gif" BORDER="0"> If it does, though, I'll try a new pump. <p><TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote »</i></TD></TR><TR><TD CLASS="quote">How's the car been treating you otherwise?</TD></TR></TABLE><p>Just fine-all I've had to do is change the oil and put new tires on it. Everything else has run like clockwork. The transmission whines sometimes when I'm accelerating hard for the first time in a given day, but it doesn't happen for the remainder of the day (and it doesn't do it every day, either, which is really strange.) I'll probably be checking the fluid this weekend.<BR><BR>
<i>Modified by TheJeffers at 12:45 AM 9-19-2009</i>
 

·
Registered
Joined
·
3 Posts
Ok seem like this is a common problem of our 960, cuz my car does the exact same thing too! It is a 97 960, the noise is there since I bought it two years ago with 150K and now it has 184K, just nagging but never gets worse...
 

·
Registered
Joined
·
247 Posts
Re: (M-POWER)

Are you guys experiencing just a noise, or also stiff steering when trying to turn off-center? The upper and lower u-joints on the steering column (in the engine bay, in ahead of the firewall) may also be culprits.
 
1 - 7 of 7 Posts
Top