SwedeSpeed - Volvo Performance Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi all,

I'm having troubles with my wagon today. I went into the store to do some shopping and when I came out it started and revved to 2k normally, settled down to 1k, idled badly, then died. It took a little cranking and some gas to get it to start again and I tried keeping it alive with the gas pedal but it would just idle sporadically and die. I can hear the fuel pump priming when I turn the key. I had a couple of extra fuel pump relays from the junk yard in the glovebox and I tried those out to no avail. I unplugged the MAF as well, but that didn't work either.

Tomorrow I'm going to clean the throttle body and the IAC. The PCV system has been done recently, but I also just found that I didn't connect the crankcase tube very well as it was off the engine, so I reconnected it about a week ago. I did notice that my distributor cap didn't look all that great when I had it off the car recently. I guess I didn't try jumpering the fuel pump relay contacts either. Can you think of any other places I should look to figure this out? Thanks for any help.
 

·
Registered
Joined
·
92 Posts
Just curious, but how did this work out? Only asking cuz my IAC caused my 95 manual to stall when it was cold and when I took it out and cleaned it, the problem immediately went away... Very gratifying! But I do like to know other solutions to these kinds of issues for the future as I think most of us do...
 
1 - 2 of 2 Posts
Top