SwedeSpeed - Volvo Performance Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter · #1 ·
I took my car in two weeks ago for the 15k mile service and a list of other things to be fixed. Based on how well the list was completed I question wether the 15k service was completed. Some of these problems are the same as most, front armrest button sticks so it wont latch closed, rear armresr fell off hinge so it wont go all the way down or all the way up. These two were fixed. <p>I have a clicking noise and a feel in the clutch pedal when it's pushed in and let it out, its at the same spot and happens in warm cold wet or dry. They told me theres a spring that needs to be replaced because it gets caught up and snaps on another piece, thats the feel and noise I get.<p>Since the second day I've owned the car the radio will stick on a station the first time I try to change it either pressing the wheel control, the preset or using the tune knob. Turning the radio on/off clears it. This was the 5th time its been in for this, the first few they didnt have the software patch yet and then they couldnt get the car to accept the patch. After numerous failed attemtps they said they would replace the am/fm tuner (30732565-4).<p>They coulnt hear the seat belt squeek, I'd say its because the radio was on but that doesn't work maybe the clutch made too much noise.<p>Ok so I tell them Im going to be out of town for two weeks so take yor time and fix it right there's no rush. I get in it and the first thing I hear is the clicking clutch <IMG NAME="icon" SRC="http://www.vortexmediagroup.com/images/banghead.gif" BORDER="0"> <IMG NAME="icon" SRC="http://www.vortexmediagroup.com/images/banghead.gif" BORDER="0"> I go back in and a tech takes it away and says there's a spring that is part of a whole assembly that sticks, Ive adjusted it but it may have to be replaced, its been here two weeks you could have built a new car in that amt of time. today I get in my car and the radio sticks to a station when I try to change it. Here are some of my questions. To replace the tuner would any cd's that are in the deck have to come out, the three that were in are still in their same places. On the face of the radio you have the temp settings on the bottom right well to the left of that I now have "Reg", it's the same size as the "3ch" on the other side. Ive read the owners manual and couldnt find anything, what is that. They said the original clutch spring and tuner had to be ordered but since the spring wasn't done I now wonder about the radio. <p>It's a long post but I've gone a long time with these problems <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/mad.gif" BORDER="0"> <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/mad.gif" BORDER="0">
 

·
Registered
Joined
·
324 Posts
Re: 15k Service??? (Nairb)

Sorry to hear about your problems; I hope you get it resolved.<br>Also sorry I can't help, I have 15k also but none of these problems.<br>Good luck.
 

·
Registered
Joined
·
173 Posts
Re: 15k Service??? (Nairb)

I had the exact same radio problem. It was corrected at the first scheduled service with some kind of software fix. Greg
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #4 ·
Re: 15k Service??? (Gregd)

I would have thought mine would too. Where is the "tuner", I also would have thought that to replace that they would have to remove the cd's.
 
1 - 4 of 4 Posts
Top