SwedeSpeed - Volvo Performance Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Help! I have a 2012 model year XC60 (made for the Canadian market) and have installed a 13-pin European trailer harness (needed for my European Thule bike carrier, which comes with a full set of rear lights (position, brake, fog, reverse and amber turn lights, the latter as well as the fog and reverse lights being practically unheard of in North America when it comes to trailers and other towed items.)

This same harness worked fine on my 2004 V70 (also a Canadian model) but that was before trailer modules became the norm. The connector being different at the ‘inside' end of my harness I therefore exchanged it to one designed for the trailer module (the module is Volvo part 31350479) and spliced each wire to the connector according to www.matthewsvolvosite.com wiring diagram for the XC60. The result was a harness similar to Volvo part 31373184. I then connected the harness as well as the two pre-wired (existing) power & data connections under the floor mat to the module, using Volvo extension harness 31346554. Of course, Pins 3, 11 and 13 were grounded as per instructions in http://accessories.volvocars.com/AccessoriesWeb/Accessories.mvc/en-US/CA/XC60/2012/T6 AWD/Automatic/L.H.D/ShowDocument/ShowIiDocument/VCC-452672-1/XC60_2012 .

Once the above completed, I brought the car to the Volvo dealership to have the trailer module programmed by their VIDA system. They say that their VIDA was set to install the 13-pin programme.

Well, it didn't work. The dealership claims that I must have done something wrong. Back home, with a multi-tester, the wiring diagram and the Volvo installation instructions, I confirmed that my connections were correct. I've asked Volvo North America to confirm 13-pin harness is compatible with my vehicle. They are looking into it.

In the meantime, can anyone out there provide me with useful comments?
 

·
Registered
Joined
·
4 Posts
Well, I installed my removable towbar hitch last week and next Thursday I´ll take the car to the dealership to activate the trailer module.
I bought the parts from a dealer in UK because here in Brasil Volvo still not have the approval from the local regulations to sell it but before purchase the whole kit I took all the attention to make sure it was correct.
The parts list is:

31269504 - Towing Hook;
31373184 - Cable Harness;
31350479 - Control Unit;
31346554 - Cable Harness;
30758125 - Casing

My dealeship told me this is universal (electronic components) and should work in any market, check the 40A fuse is it´s assembled correct and the Orange Wire that will go to the fuse box ifi it´s fully down in the bay.

Regards
 

·
Registered
Joined
·
32 Posts
Reviving this old thread...

jcxc60 : did you resolve your issue? I'm installing a trailer hitch on a 2013 S60. So far I've installed the trailer module 31350479.... which is the same as you...

From what I can tell, the pinout is the same for all version of the load.. it is not load-dependent.

When looking at the module, with the "clip" of the connector facing upward, there are 2 rows of 6 pins.
1 --- 6
7 --- 12

When looking at the wiring connector, these are the pins :



The pinout is ALWAYS :
01 Backup
02 Not Connected
03 Ground
04 Unused
05 12v when ignition is on
06 Permanent 12v (vehicule specific)
07 Parking Right
08 Parking Left
09 Right Flasher
10 Left Flasher
11 Brake
12 Fogs
 

·
Registered
Joined
·
32 Posts
Scratch that.. seems this is the pinout for 2013 models... not for 2012 even if they are using the SAME module with the SAME load as is 2012

I cannot wrap my head around this...

31350479 <-- This is the part number of the trailer control module... for XC60.. 2009-2013

30764681 <-- This is the part number of the software load for 13 pins on XC60, 2009-2013

Acording to vida AND the wiring diagrams
2009-2012 Pinout when using 13pin wiring harness
01 Right Flasher
02 12v when ignition on
03 Left stop lamp
04 -
05 -
06 Backup
07 Right Stop lamp
08 Fog Lamps
09 -
10 Left Flasher
11 -
12 Parking lamps

2013 Pinout
01 Backup
02 Not Connected
03 Ground
04 Unused
05 12v when ignition is on
06 Permanent 12v (vehicule specific)
07 Parking Right
08 Parking Left
09 Right Flasher
10 Left Flasher
11 Brake
12 Fogs

I don't understand how the same module, with the same load can have different pinouts...

Now, for the wiring harnesses, there are 3 models with 13 pins.. still for the XC60

31324672 <-- Chassis less than 261716
31346164 <-- Chassis between 261176 and 293186
31346526 <-- Chassis between 293187 and 364999

My only guess here is that there are 3 generations of pinout and that for some reason, the programming is not the same... it carries the same part number.. but does different thing for different years...

this is messy...
 

·
Registered
Joined
·
333 Posts
A 13-pin should include permanent 12v, fog and reverse light. The 2012 one you have listed looks more like a 7-pin wiring, kind of?


Speaking of trailer modules, I know they were updated not long ago to support LED lights on the trailer. Not sure if that has anything to do with the difference between the modules you have listed?
 

·
Registered
Joined
·
21 Posts
I don't understand how the same module, with the same load can have different pinouts...
...
this is messy...
If the module uses modern programmable FPGA hardware then the physical hardware can be programmed to do different things. Depends on what they put in the black box.

I'm digging as my "new to me" 2011 XC60 with 7 pin harness is not putting out 12V anywhere on the 7 pin connector. See a 40A and 15A fuse position, but the 15A fuse position has no wiring/fuse... wondering if thats to power a 13 pin connector? At any rate.. I'm trying to understand why the trailer connector has no 12V... still poking at it with a DMM.. I was at the trailer side, need to go to the volvo side...
 
1 - 6 of 6 Posts
Top