SwedeSpeed - Volvo Performance Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi, I am in need of some help and advice.

I own a 3.2 I6 2008 S80, and when I start the car it makes the noise shown in the video attached. This video is of my S80. It’s got 126k miles on it, and it only makes that sound when it’s idling in park or neutral. When in drive, it makes a similar sound, but it’s intermittent, and it’s a faster more frequent rattle because the engine RPMs are up. I really need some advice as I move into college at the end of this week. Does anyone have any ideas??

http://youtu.be/Df4W_BxTg_w
 

·
Registered
Joined
·
798 Posts
First, you should post in the S80 forum to get more responses.
https://forums.swedespeed.com/forumdisplay.php?102-S80-(2007-2016)

I can’t make out the audio in your clip due to distortion. However, one reason for engine rattle can be worn out engine mounts. The upper one is easy to replace. I believe there are two more, but hard to do yourself because of limited access.
 

·
Registered
Joined
·
421 Posts
It possibly could be that the membrane in the PCV Oil Trap has ruptured. The way you can tell is that the sound will stop when the oil filler cap is removed, and resume when put back on.
 

·
Registered
Joined
·
27 Posts
Any update to this? I'm dealing with a similar noise on a 2007 S60R. I've been chasing this for a few months now and this is the only similar noise I've heard to mine. My noise is not there at all in the cold only during 50°F plus weather. I've had half a dozen shops take a crack at locating the noise and my self and several buddies hunting it down.

It's to the point that me and a few guys have a betting pool going for it.

Also I am the one who asked on your YouTube clip
 
1 - 4 of 4 Posts
Top