SwedeSpeed - Volvo Performance Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
195 Posts
Discussion Starter · #1 ·
Story goes, couple weeks ago loose all controls on the column minus one speed of wipers and the horn. Shop tears into it, all signs point to steering wheel module, put a new one in, car is perfectly happy for a few days. Last week it decided it had enough of working properly and starts giving me this light show randomly, rain or shine, cold or warm. Where do I begin my quest for answers oh wizards of Swedish engineering?

 

·
Registered
Joined
·
8,061 Posts
Such a story would make me suspect bad connectivity. Due to the adjustable steering wheel there is a wiring bundle that connects to everything in it with enough slack to allow its movement, so I'd carefully inspect it first to see if its damaged or frayed which could cause behavior like this. Also make sure to check the fuses involved too just to make sure something obvious wasn't missed by the shop.
 

·
Registered
Joined
·
8,061 Posts
The clock spring connector wouldn't explain the turn signals being part of the problem unless its shorting a power supply for the colunm, which is why I suspect the column wiring.
 

·
Registered
Joined
·
438 Posts
I was thinking that the clockspring dying might kill his steering module earlier. I think its key to understand if the only thing left is the light show, or if other stuff is borken.
 

·
Registered
Joined
·
195 Posts
Discussion Starter · #6 ·
Lights on, controls work, lights off, controls dont work. We'll fiddle with the harness tomorrow, I was wondering if it could be something in the rest of the harness but its not moving, nothing is dangling or has any free movement to possibly short out.
 

·
Registered
Joined
·
438 Posts
Do you mean only steering wheel controls or turn signals/etc as well?
 

·
Registered
Joined
·
8,061 Posts
His vid demonstrates it also makes the turn signal go out. If the harness looks good it may be worth pulling the wheel to look at the clockspring to make sure its not frayed and shorting out the whole column.
 

·
Registered
Joined
·
195 Posts
Discussion Starter · #9 ·
New module installed, no change. Next step is to scope test the harness to make sure everything is actually communicating as it should be, if not we start looking more at the CEM. We have some idea that we may be getting signal one way but not the other as when the modules are activating intermittently things dont happen right away when keyed.
 

·
Registered
Joined
·
195 Posts
Discussion Starter · #10 ·
Sent the CEM to Xemodex to be tested and they have had absolutely no issues with it so far, at this point the technician has put the scope to the harness and checked for continuity on all the wires which there is, the steering wheel module has been replaced twice, the stalks are new. Were running out of options here.
 

·
Registered
Joined
·
438 Posts
I agree clockspring


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
195 Posts
Discussion Starter · #13 ·
Why would the clock spring affect items not connected to it though?
 

·
Registered
Joined
·
438 Posts
A short in the clockspring would cause the upstream module to become inoperative. If the module was sophisticated as I have seen with some of the others, its output protection would prevent damage to the module with a shutdown temporarily. If the module was dumb it would burn up or blow a fuse.

I also somewhat note that FCP has the clockspring on their site under steering. They seem to only keep more popular parts in the odder categories.

And a final note, depending on the design of the clockspring, on some cars a catastrophic failure can cause airbag deployment


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
438 Posts
I am having this behavior now, but less serious. The left side lighting for the buttons is intermittent.

I just removed my whole dash so I suspect that as the culprit.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
195 Posts
Discussion Starter · #16 ·
I am having this behavior now, but less serious. The left side lighting for the buttons is intermittent.

I just removed my whole dash so I suspect THAT as the culprit.


Sent from my iPhone using Tapatalk
And what is that?

Recieved the unit back from Xemodex, tested out a-ok but they exchanged another known working unit for mine to test and see if it was something in my cem they couldnt see. A+ customer service for sure!

Will update Monday if it fixed it, if not I'll try the clock spring.
 

·
Registered
Joined
·
195 Posts
Discussion Starter · #17 ·
Welp, No dice. Oddly though the technician put the original steering wheel module from the VR back on and it started working intermittently again. We've ordered a third SWM to try, this is getting ridiculous.
 

·
Registered
Joined
·
438 Posts
No clock spring available?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
195 Posts
Discussion Starter · #19 ·
No clock spring available?


Sent from my iPhone using Tapatalk
We also oredered a clock spring to test with but theres nothing to point to its failure.
 

·
Registered
Joined
·
438 Posts
Xemodex is excellent. If thy say your module is good they are probably right.


Sent from my iPhone using Tapatalk
 
1 - 20 of 21 Posts
Top