SwedeSpeed - Volvo Performance Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter · #1 ·
Hi I have a 98v70xc, I talked my best friends into buying a 05 v70r because they are expecting and needed a safe car, picked it up on sunday all fine everything is great, yesterday they get a srs service light urgent come up on the display, they also mention the dash lights and the ccm didn't come on during start up and the drivers seat wouldn't move. Beacause it was srs related it was off to the stealership, luckly there was no charge.

Here is what they found, they said they didn't know what casued it and it may never happen again.

cem 1a54 com with psm control module missing dtc is found not active
cem 1a55 com with ccm control module missing dtc is found not active
cem 1a56 com with dim control module missing dtc is found not active
ecm 660b MIL signal missing dtc is found not active
srs 00d5 srs lamp signal missing dtc is found not active

Please help I feel really bad talking my best friends into buying a volvo then this happens
I'm no mechanic but I know my way around a tool box so I hope I can help them keep it out of the stealership

I also have access to vida now and have been looking for loose conections checking for power, and ground at the cem, I'm hoping this is a cem issue since theyare rebuildable,I understand that the 05 DIM is not repairable. these codes now come back everyday, less than 24hrs, the only thing that seems to affect it is that if the caris outside in the cold weather the fault happens everytime the car is started some times it takes up to 10 minutes for the lights to come on, on the dim and ccm, the the srs urgent light is on, when the car is parked in a warm garage the problem does not happen as often.

I hope that someone can shed some light on this I realy want to fix this for them
 

·
Registered
Joined
·
3,313 Posts
Maybe a bad/old/drained battery - when starting the car the battery is getting drained very very low as it starts, does it start slowly or crank a little slow? I get that when my battery is drained, not the SRS error but alarm error or something else but goes away as the car gets to idle and Alternator kicked in fully.
 

·
Registered
Joined
·
308 Posts
I would've said weak battery as well. Similar thing happened to both my Rs when the original volvo batteries started to go.

Make sure the battery is the correct unit. These cars are extremely picky when it comes to powering all of its modules.
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #8 ·
I checked the ground its good, I got the same codes last night too, I checked the voltage of fuse no.10 on the cem since it powers the dim,ccm,psm I got 14.4volts the DIM and the CEM are off no lights no function, nothing. then I switched the car off as a switched it off the DIM and CCM lights flashed as the key was in postion 1 then I started the car again everything worked as normal, but have the srs urgent light on again as i expected. I know that seeing 14.4 volts at fuse no.10 was not what I was hoping for, I was hoping I would see no voltage during the fault, But I'm still leaning towards the cem being the fault, I think it might not be distrbuting its power correctly, sometimes if you leave the car running the DIM and CCM, and PSM will start working on their own but it can take up to ten minutes, its quicker to turn the car off and try again all test are being done in aprox -15c, any more ideas?

PS when I first went to start the car postion 1 evrything is normal, postion 2 everything is normal, when go to postion 3 when the greatest load is on the car thats when the fault occurs. Its like the car is turning the DIM,CCM, and PSM off to insure the car starts.
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #9 ·
UPDATE

I took a gamble and removed the cem sent it to xemodex, no usual fault was found with the cem. a new fault they had not seen before was occuring. they wanted to keep my cem as a test unit. they were good enough to replace my cem. I am happy to say it is installed and no faults yet 24hrs has passed with multiple trips out in the cold -20c with no faults so pleased so far highly recommend xemodex the tech support and service, are second to none.
 
1 - 10 of 10 Posts
Top