SwedeSpeed - Volvo Performance Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
I have been chasing an sputtering 05 M66 SR at cold idle for about 4 weeks now. Video below:

http://youtu.be/Lll8dYDw00I

2005 SR M66 91K. Mobile 1 since delivery, all scheduled maint, timing belt replace @ 71K due to failed pulley(under warranty).

I have replaced the following parts: plugs, coil packs, fps, maf, fuel filter, tcv and battery. No codes found in VIDA and no CEL. Found no vacuum leaks, cylinder compression within tolerance, fuel rail pressure normal.

Sympton still exists after multiple ECM reset and dealer reset ECM adapations.

Dealer found the following issues during "open diagnostics": stuck ejector valve; replaced and the hose connection. Resting fuel pressure low; they stated a valve in the fuel pump stuck open and fuel is leaking back to the tank (pump replaced). Residue found in the turbo inlet (replaced). Dealer stated all of the NGK plugs were fouled and replaced with Volvo plugs.

Very lost now...any help would be very appreciated.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #3 ·
Just a quick update to the status: all injector tested with no leaks and spray pattern normal. Valve leak test also normal. Techline offers no other solutions and waiting for a Volvo Field Rep now.
 

·
Registered
Joined
·
3,157 Posts
Have they checked the vacuum for the PCV system (they have to hook a manometer up to the dipstick tube while it is idling - vacuum should be -0.2 kPa or lower) and/or checked that the calculated throttle body leakage (indicative of a dirty throttle body) is within spec?

From your original post, it sounds like they already checked the EVAP purge valve, which was the other thing that I initially thought of.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #5 ·
The ventbox was replaced and vacuum pressure is now normal and at the same time the throttle body was cleaned.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #6 ·
Per Volvo Field Rep. Injector #3 going bad and replaced. Should have it back today.
 
1 - 6 of 6 Posts
Top