SwedeSpeed - Volvo Performance Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
153 Posts
Discussion Starter #1
Today this msg popped up. Key fob stopped working. Unlocking car with the metal key set's off alarm but no sound. I did some searching online and was only finding info on alarm module issue's on P2 cars. Has anyone had this issue on a S40? If I order a brand new module from Volvo does it work , or does it need some kind of software ? Thanks for any info. Greg
 

·
Registered
Joined
·
2,361 Posts
I had an issue where the alarm module's internal rechargeable battery was going bad and the alarm would sound randomly. The battery pack is custom made of rechargeable coin-cell batteries. I was able to find a same spec but different shape pack and modified the case to fit.

There is a fuse that you can pull that may get you running. You will still get the message on the screen.
 

·
Registered
Joined
·
153 Posts
Discussion Starter #3
Thanks for the information. Do you remember the voltage of the battery ? I see some battery's on E-bay for the P2 siren module. No idea if they are the same. I would like to just slap a new module in. No idea if it needs programming. Is it normal for the key fob to stop working when this module goes bad ? Once the alarm is set off with the metal key the unlock button on door will not work until you start the car.
 

·
Registered
Joined
·
2,361 Posts
I attached my How-To
 

Attachments

·
Registered
Joined
·
943 Posts
Sounds like you alarm is fine. It works. Sounds like you have a bad battery in your fob.

If battery is good in the fob, you may need a module reset. Disconnect the car battery positive cable from battery, jumper it to the negative battery cable for about 20 mins or so. Disconnect the jumper and reconnect the positive cable. Try your fob and see if it works. This has worked for me on at least 2 different P1 Volvos. Glück.
 
1 - 5 of 5 Posts
Top