SwedeSpeed - Volvo Performance Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
Greetings fellow Volvo lovers and fans,

I have a conundrum that begs to be examined closely. I have an XC90 AWD 2.5T that won't start. Message on the dash reads immobilizer, read manual. But before anything else, I'd like to give you all a quick history of the said vehicle. I have had it for a year and 5 months now. It had 162K miles when I bought it for and incredible price but of course with some issues I was able to address and fix. It also had issues with the anti theft / factory alarm system but it still kept running until now. At 178K miles, it refused to start and it threw out that message on the dash and I went ahead and checked for codes even though the was no CEL triggered. Computer says no issues. I read the manual about the immobilizer ( start inhibitor ) and all it saying is that if the key is properly coded, this will start the car. I happen to have only 1 key and it is the master key. It has never been modified or changed and I have since replaced the fob battery when I noticed a weakness in it's range in locking and unlocking the car remotely. I have also tried the 5 time lock, unlock process via the door lock of the driverside and using the remote to lock and unlock 5 times straight. I am at a loss and I was hoping for some insight as to how to proceed. Thank you all so very much.:confused:
 

·
Registered
Joined
·
1,199 Posts
A lot of these weird problems can be related to a bad battery. Either that or your immobilizer ring is bad. When you say it had alarm issues, what were they exactly? Is it related to the siren being bad?

Sent from my SHIELD Tablet using Tapatalk
 

·
Registered
Joined
·
94 Posts
Battery. Key ring. Bad CEM. Fuel Pump Module (PEM). Just some guesses. I had similar issue.....was a bad PEM.

Sent from my SM-G900R4 using Tapatalk
 

·
Registered
Joined
·
3 Posts
What are the odds, I just finished switching out my crankshaft position sensor, go to start the car no tic or nothing and "immobilizer - check manual" came on... Sitting here trying to figure out what's wrong think it may be a relay but I'll let you know
 

·
Registered
Joined
·
3 Posts
Also talked to a local Euro mechanic said it could be that the key was disprogrammed - hoping it's not that as Volvo absolutely loves charging like crazy for that
 

·
Registered
Joined
·
120 Posts
It's not the key. Unprogrammed or lost key program will have " Starting prevented" on display.

The same problem on P2s is a corroded immobiliser module which is located behind the passenger side plastic guard liner. The battery on the immobilser board has leaked acid and caused the immobiliser board to shut down. If the acid hasn't eaten the copper tracks away you can remove the old battery and buy 2 x 3.6 volt cells and solder them back onto the board in series.

If it's beyond repair you'll need a new or used immobilser board. It doesn't need programming to the car. There are detailed repair procedures on MVS if this forum doesn't have info.

Sent from my SM-N910G using Tapatalk
 

·
Registered
Joined
·
1,199 Posts
Do you mean the siren? Cause mine had an exploded battery and the only thing I couldn't do was open the sunroof until I removed it. I eventually replaced, but never had a problem starting it without the siren plugged in, or the battery exploded all over the board.

Sent from my SHIELD Tablet using Tapatalk
 

·
Registered
Joined
·
120 Posts
Perhaps I DO mean the siren module. I'll have to check over on MVS to be certain. However it's the same message on display.

Sent from my SM-N910G using Tapatalk
 
1 - 8 of 8 Posts
Top