SwedeSpeed - Volvo Performance Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I blew my CV joint 2 weeks ago and just put the new part in last night along with new control arms and sway bar end links and inner and outer tie rods, i know i need an alignment but everything seemed to be working fine until I did a hard launch, ABS warnings came on and now it seems like my ABS is activating on its on while driving, the car is parked now but driver tire looks kinda flat and I have a second brake warning. I cant remember what exactly the codes said but one was ABS needs servicing and the other one was a warning that my braking system had something wrong. anyone ever seen anything like that?

Problems i noticed on a short ten minute drive:
ABS and other braking code
Tires squealing intermittently (like the braking system didn't unlock till after I had moved a good 20 feet)
car seemed to be braking on its on while shifting gears

that's all i noticed but I'm sure there was more I didn't hear or feel.

I drive a 04 S60R

HELP!?!?!
 

·
Registered
Joined
·
1,674 Posts
Double check the abs splines on the cv, check the wire for your abs sensor and brake fluid too.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
I checked the Abs splines, the sensor and the brake fluid, but nothing changed so I ended up reflashing the ECU and that got rid of the codes. after a quick hard drive nothing came back on. but I noticed that my passenger side wheel bearing was shot, so I replaced that. after putting everything back together and putting it back on the ground I started to pull out of the shop and POP. turns out my inner cv joint had pulled itself out.

I had double checked everything and it all looked good but ended up destroying the bearing cradle. jacked it back up took the cv out and replaced the cradle with the cradle from my old CV and made sure that it didn't pull itself out again while I installed it. drove it for two hours then parked it (no problems). next day I went out to drive it again and it drove fine. took off from a light got it into second then tried doing a pull, car started vibrating, my friend thinks the CV is slipping, a mechanic things the inner CV joint has a messed up bearing.

I'm pulling it into my shop to replace the rear springs, sway bar and sway bar end links then I'm going to work on the front and so the same but I'm not sure what would be making the car vibrate the way It did.

should I take the CV out again and take it apart to make sure everything inside is good? or would it be something else that is causing this?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
What CV did you use for replacement?
I used OEM, the cv I put in came off of a different S60R, I looked at it again today and everything is set properly but I took it for a quick pull and same thing happened, but when I did it with a friend in the passenger seat it didn't do it. I know that my front springs have been cut, something the kid before me did... but I didn't think that cut springs would affect it but could that possibly be the problem?
 

·
Registered
Joined
·
316 Posts
I used OEM, the cv I put in came off of a different S60R, I looked at it again today and everything is set properly but I took it for a quick pull and same thing happened, but when I did it with a friend in the passenger seat it didn't do it. I know that my front springs have been cut, something the kid before me did... but I didn't think that cut springs would affect it but could that possibly be the problem?
I dont think that would set ABS codes, more likely you would get suspension errors. I would check the ABS sensor, the wire is now old and they are fragile to begin with, could have been damaged when doing the suspension work.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
I dont think that would set ABS codes, more likely you would get suspension errors. I would check the ABS sensor, the wire is now old and they are fragile to begin with, could have been damaged when doing the suspension work.
I checked everything after installing the part but ill hook it back up to a computer and see if there are any codes being shown now, but I don't understand why it would be abs stuff when it feels like the cv is slipping.
 

·
Registered
Joined
·
1,273 Posts
Dumb question: axles bolts have been tightened up, right?


2002 V70XC, 2003 V40, 2004 S60, 2010 V70
 
1 - 8 of 8 Posts
Top