SwedeSpeed - Volvo Performance Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
295 Posts
Discussion Starter · #1 · (Edited)
I'm getting boost flutter after I installed a fmic last weekend. The car runs perfectly until full throttle at >5000 rpm when I can feel it hesitating and not getting full boost. I checked for leaks with soapy water and found absolutely nothing. I'm leaning towards a bad tcv or a weak cbv spring/deteriorated diaphagm. Any other thoughts or input?

Car is an 04 V70 2.5T fwd with a 16t, 3" turboback and the stock tune. It has fresh plugs, fresh coilpacks, a new pcv system and all new vacuum lines, 144k.
 

·
Registered
Joined
·
7,614 Posts
16T is an upgraded turbo for that motor, right? You have a completely new induction, boost, and exhaust system, everything I've read says you really ought to get a new tune. Have you disconnected the battery and let the car try to re-learn the setup?
 

·
Registered
Joined
·
295 Posts
Discussion Starter · #3 ·
The tune is the next step, but I had to get all the pieces in place first. The 16t and exhaust have been on for months and I got zero flutter until immediately after installing the ic.

I did think about letting the ecu re-learn, so I pulled the fuses for a couple minutes yesterday. I drove about 20 miles after and the problem was still there, though it seemed to be getting better...but that could just be my imagination.

sent from...
 

·
Registered
Joined
·
11,936 Posts
You have enough new parts that the stock tune might never work well at extremes of throttle/RPM/boost/etc...
 

·
Registered
Joined
·
63,543 Posts
Agreed,
Now that it's 100 times more efficient, the engine probably can't handle that much air in the most efficient way
 

·
Registered
Joined
·
295 Posts
Discussion Starter · #6 ·
True....the fmic and larger piping may just simply have pushed the system past the point of supplying more volume of air than the ecu knows what to do with. I am getting an intermittent overboost code.

Guess I need to expedite that tune!

sent from...
 

·
Registered
Joined
·
295 Posts
Discussion Starter · #7 ·
Bumping this back up because I found the problem. Took advantage of ipd's black friday sale and ordered a stock tcv and an ipd hd cbv. I put the tcv on this morning then took it for a drive before I tackled the much more difficult cbv job, and holy s***! Boost is much stronger through the entire range and never falls off....plus I can feel and hear it open the cbv a split second before each shift, so that project is getting put off until I get the tune and need the stronger spring.

I'm very happy overall, this car is getting fast! Even with a ton of wheelspin in first and second gear it hit 60 in about 5.5 according to the stopwatch on my phone.

sent from...
 

·
Registered
Joined
·
57 Posts
Funny about the TCV's... I installed a Phuzzy tcv the other day, and the motor reacted horribly. I had it on for about 3 days, approx 500km's of driving, and I removed it, and put the factory TCV back. Car drove much better.

I have read a lot about the CBV replacement, but I don't really like the idea of tackling that job. I expect it to be a royal PITA. Plus, I am thinking about upgrading the turbo. I have the 13g from the LPT, but I don't really have the budget right now to buy a bigger 16t, and then get a tune as well.

I saw on facebook that Lucky has a new billet 19T refurbished cold side for $600. That's interesting! But then ad an additional $400 for a tune, and suddenly my 13g seems just fine :)
 

·
Registered
Joined
·
4,017 Posts
Time to call Lucky at ARDideas.com for a great tune.
 
1 - 9 of 9 Posts
Top