SwedeSpeed - Volvo Performance Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I *think* the alarm might be randomly going off on my 03 XC90 but I'm not entirely sure.

Since about the time we got the car an alarm has been going off on our street for a short time (about 30 seconds) and seems to stop when I press the unlock on my key fob (but it could be a coincidence of just getting to the end of the 30 seconds).

I say I think its my alarm because none of the lights flash when the alarm is going off (should they?) and I get no warning on the dash that the alarm has been triggered (LED doesn't flash and no message).

I tried the "panic" alarm button on my key fob to see what my alarm should sound like but this let out a VERY LOUD alarm so I'm assuming it isn't the same alarm as the intruder alarm (or is it?).

I've taken a look to see if the ECU has any fault codes and nothing is active or pending. There is only 1 historic code (P0244).

Anyone know if it is my alarm that is going off and if there is any way for me to check other than just waiting vigilantly for it to happen again?
 

·
Registered
Joined
·
26 Posts
Hello,

This worked for me so you could give it a shot if you'd like.

I have a 04 xc90 and this past spring my alarm would keep going off at random times throughout the day for no reason. The day after I realized this though I was supposed to be leaving for the Bahamas for a week and didn't have time to deal with it so I pulled the fuse for the alarm and left the next day.

After returning from my vacation I decided to leave the fuse out until I had time to bring it into the shop, but a few days later my sunroof stopped working :thumbdown: and I remembered reading something about the alarm and sunroof coordinating some how. So I plugged the same fuse back in and to my surprise the sunroof started working again. Not to mention the fact that it's been months and my alarm has not gone off once...other then me testing it to make sure it's still working. :cool:

My turn signals would flash though when the alarm had been triggered and the dash would say "alarm triggered". So your current issue could be something different from what I experienced, but again you could always give it a shot.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I got in the car today after work and the LED was flashing quickly and the dash said "alarm triggered". Looks like it might be getting worse.

I have pulled the fuse out and will leave it a few days before putting it back in. Hopefully it'll solve it.
 

·
Registered
Joined
·
3,251 Posts
http://forums.swedespeed.com/showthread.php?215154-2006-xc90-alarm

Or cut to the chase, see this thread http://forums.swedespeed.com/showthread.php?141244-XC90-alarm-going-off-by-itself, subpost #17.

If it's not a failing (leaking) battery inside the siren module, you'll be a rare exception. Could be that you have a motion sensor in your car that's causing trouble, I don't have one of them. But I did in fact have a leaking battery inside mine and acid was all over the PCB when I opened it up.
 
1 - 4 of 4 Posts
Top