SwedeSpeed - Volvo Performance Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter #1
Hi All

So as I was driving along on I-95 in Philly, suddenly this ESSR light lit up !! Car doesn't experience any performance problem / no hesitation nothing as I was just driving without any problem.

Is this an early symptoms of a failing ETM / bad MAF ? I am taking the car in 2 days to my indi .. do you think it is okay to drive ..don't wanna have the car going into a Limp Mode with an 18" wheeler tailgaiting me :(

ETM has been replaced as it has the yellow sticker on it.

Any input , greatly appreciated.
 

·
Registered
Joined
·
313 Posts
Probably fine to drive. Mine was the ETM. Unfortunately I was on my way out of town when mine started throwing codes and didnt have time for an indi shop.
 

·
Registered
Joined
·
63,541 Posts
Probably
Your miles would help along with when the ETM was replaced
MAF, it could be anything, you need to pull codes
 

·
Registered
Joined
·
137 Posts
Discussion Starter #4
Thanks guys. For some weird reason, the message was gone overnight. Still going to have the indi checked it tomorrow.

JRL : Your white XC is really nice as you pulled in picking up your guest at Devon Courtyard this past weekend :)
the wheels looked perfect
 

·
Registered
Joined
·
137 Posts
Discussion Starter #5
Found the problem ! nothing major as the message went away.
VIDA Found ECM-9400 Brake pedal sensor signal high / intermittent fault. Decided to ignore and move on.
Thank you again for all the inputs.
 
1 - 5 of 5 Posts
Top