SwedeSpeed - Volvo Performance Forum banner
1 - 9 of 9 Posts

·
Registered
98 S70 Base, 06 S40 T5 M66 FWD, 08 C70 M66, 11 XC90 V8, 13 C70 P*
Joined
·
951 Posts
Discussion Starter · #1 ·
Yay, it’s my turn to deal with this stupid design flaw. Died on DW in a parking lot not too far from home. Once again, thank you Michael for blazing the trail and posting the fix. Won’t be able to get to it until the morning, but at least I know what I have ahead of me when I do.

https://www.youtube.com/watch?v=dKCAlsrl1jg&feature=share

BD


Sent from my iPad using Tapatalk
 

·
Super Moderator
Joined
·
15,188 Posts
Good luck with it! Some people have reported having their column lock riveted in place rather than a screw, so it might take a bit of work to get it out. But it's pretty much the same method.
 

·
Registered
98 S70 Base, 06 S40 T5 M66 FWD, 08 C70 M66, 11 XC90 V8, 13 C70 P*
Joined
·
951 Posts
Discussion Starter · #3 ·
Thanks, Michael. Yeah, I saw that in some of the comments to your video, and sure enough mine is riveted. A little more of a hassle, but shouldn’t be too bad.

BD
 

·
Registered
98 S70 Base, 06 S40 T5 M66 FWD, 08 C70 M66, 11 XC90 V8, 13 C70 P*
Joined
·
951 Posts
Discussion Starter · #5 · (Edited)
Thanks, Tech. I still need to cut them off/cut a slot in the head to unscrew in order to get to the problem spot though, right?

Got lucky for now. After disconnecting the wiring harness and reconnecting, it let me start it. Going to take some contortions (and a power source for my Dremel) to get the shear screws off, so glad I bought myself a little bit of time.

BD
 

·
Registered
Joined
·
5,604 Posts
Getting them out isn't too hard. Use a dremel to cut a slot in them and then use a flat head screwdriver to unscrew them.

We don't take the SCL apart at the dealer for liability reasons. I just replace them.
 

·
Registered
98 S70 Base, 06 S40 T5 M66 FWD, 08 C70 M66, 11 XC90 V8, 13 C70 P*
Joined
·
951 Posts
Discussion Starter · #7 ·
Well, as Michael notes in his video for the temporary fix, it’s only a matter of time before you have to take out the SCL again and mess with it because it locks up. Went ahead and ordered a new one from FCP.

Just got it tonight and plugged it in, but no go. Just get the “Steering system service required” message and no movement of the lock inside. I put the old one back in and you can hear the lock disengage/it starts right up.

Tech, does the new SCL need to be programmed to the car, or did I possibly order the wrong part #? Thanks as always for the help!

BD
 

·
Registered
98 S70 Base, 06 S40 T5 M66 FWD, 08 C70 M66, 11 XC90 V8, 13 C70 P*
Joined
·
951 Posts
Discussion Starter · #9 ·
Thanks, Michael. I haven’t done a software update in a while, so may schedule a time when I get a coupon from my dealer for parts and service and get it done with a few other things.

BD
 
1 - 9 of 9 Posts
Top