SwedeSpeed - Volvo Performance Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-15 of 15 Results
  1. S40 & V50 (2005-2012)
    Hi all, I've done a fair bit of research on this but mainly wondering if I'm on the right track or in missing something. So last week I was driving my son to school (short drive!) when I realised none of my dash gauges where working and no dash lights! (but car was running!) Tinkering about...
  2. S40 & V50 (2005-2012)
    Hello, I’m having trouble with my s40. Recently my cruise control button wouldn’t work but it returned later on. While it was happening I was told my anti-skid needed service. After a day or so both came back and I was able to use cruise control. Another day goes by and it says “srs airbag...
  3. S60 (2001-2010)
    I've been looking into finding a replacement alternator for my S60 as we believe the issues its been having are caused by it and I've found a couple at likable prices but on their description, it lists Plug Clock Position and from what I understand its the orientation of the unit when mounting...
  4. General Volvo Discussions
    Hi, I own an 05 v50 and I've seen a lot of posts talking about how to get rid of the seatbelt chime which got me wondering: is it possible to change the chime? A friend modified his jeep (a different breed of beast entirely) with a custom chime card which was a fun project I had written off for...
  5. V70 & XC70 (2008 - 2016)
    When I started my car this morning after sitting out over night for a camping trip, I got the "Red Battery and Exclamation Point" warning on the dash. It apparently means battery not getting a charge from alternator?? Continued to drive it because I was an hour from my home, 10 miles down the...
  6. New Member Forum
    Hey! I'm creating this post since I am a little puzzled. Problem: My 2004 Volvo V50 has a D4204T engine and it will not start due to a complete lack of fuel. Meaning the clear fuel line running from the Fuel Filter, to the High Pressure Fuel Pump, is completely empty ( I've included a...
  7. S80 (2007-2016)
    Hi I recently bought a Volvo S80II MY07 (Type AS) D5 2.4L. The overall condition is very good, but there are some electrical things that seems to behave weird. I don‘t want to open up multiple threads, so I will try to explain all the „problems“ here. -When I activate „automatic door locking“...
  8. XC90 (2003 - 2014)
    Hang on here with me,, sorry for the long post... Hey guys, kinda new here so please be lenient. I work mostly on German and American cars. This is my second xc90, first was a 2011, current is a 2004 T6. Long story short, when I got the car it needed the CEM repaired due to water damage. Got it...
  9. XC60 (2010 - 2017)
    Hi there, I have a 2010 xc60 3.2 AWD. I was changing the turn signal stalk and while I was taking apart the steering wheel housing I noticed this cable hanging out near the footwell vent opening. I traced it back through the dash to right above the hood release but couldn't find out where it...
  10. XC60 (2010 - 2017)
    So recently my t6 started off with a lag in the push to start. I took it for a battery read, and they told me alt and battery read ok. Today I was pulling out of a parking spot in reverse, and the dash lit up like a Christmas tree, and as I was rolling in reverse the power steering locked and...
  11. XC60 (2010 - 2017)
    '10 xc60 passenger side parking light and the side marker not working. Checked connections, switched bulbs and still not working. I read they are linked together but nothing seems to be working. Any help is appreciated! Long time lurker and love this forum btw.
  12. C70 (2006-2013)
    I have a 2011 C70 T5. Love the car but I think it has something against me. I turned on the Auto Lock feature and numerous times while going down the road, the driver's side (left) door would pop open. Thankfully it is super heavy so it was completely fine. Now, no matter how I have the settings...
  13. S80 (2007-2016)
    2010 S80 3.2 FWD, 60k miles, only owner. Has anybody experienced a similar battery electrical drain? Output V of alternator while running 14 v. Battery replaced in July 2020. A couple of days in garage battery is low. Jumps and takes a charge. Suspect a system draining the battery. Any thoughts?
  14. S40 & V50 (2005-2012)
    Hello I recently got a V50 for cheap but I didn't know the state of the car or anything, other than the car looked like it has been taken care of with nothing broken and all original paperwork including sales sticker there. The car had a P0300 code along with P0301, P0303, P0304. The autozone...
  15. S60 (2001-2010)
    Several months ago I picked up an S60R for use as a winter vehicle. It’s been a great daily driver since, but when I was on the highway today I experienced an immediate and complete loss of all electrical systems, including engine, turn signals, and brake lights. The gauges on the dash are...
1-15 of 15 Results
Top